Commits


move headers from include/diff/ to include/; makes things easier for consumers


repair DEBUG build


move some definitions from the public diff_main.h to an internal header file


use buffered stdio if falling back on file i/o; this is much faster


return error instead of abort()


rename 'debug.h' to 'diff_debug.h'


avoid include statements in header files; make each .c pull in what's needed


replace enum diff_rc errors with plain errno values


fall back on file i/o in case an input file cannot be memory-mapped


KNF: use max 80 columns


KNF: function declaration return types on separate line


Kill unused variables


initial commit