Commits


refactor apply_patch to support renaming files add two helper functions (schedule_add, schedule_del) and move the guts of apply_patch into a new function `patch_file'. This simplifies apply_patch and makes easier to figure out what happens. Then, drop GOT_ERR_PATCH_PATHS_DIFFER since we allow the to rename files.


apply_patch: move sanity check early in recv_patch


pass the callback data instead of hardcoding NULL, ok stsp


fix path to the temp file used to accumulate the patch edits ok stsp


portable: enable got-read-patch Allow the libexec helper, `got-read-patch` to be compiled, portably.


add `got patch' command for applying unified diffs