Commits


rename got_commit_graph_iter_start() to got_commit_graph_bfsort() This function begins a breadth-first traversal. The new name makes it easier to distinguish from got_commit_graph_toposort().


gotwebd: guard against missig folder and file parameter in BLOB and BLAME ok stsp


gotwebd: use 'more' for the tag listing too prodded by stsp and jamsek; ok stsp@


gotwebd: render READMEs in the tree view ok tracey@


gotwebd: add patch action to serve diffs in plain text ok tracey@


gotwebd: get rid of proc.[ch] proc.c really shines when there's a network of different types of processes, potentially with a various number of instances each, that needs to exchange messages. Gotwebd instead has a much simpler design, and using proc.c causes more overhead (/headaches) than it solves. So, this attempts to provide the same functionalities but with a much simpler implementation that fits gotwebd better. ok stsp@


gotwebd: fix branches modification time with show_repo_age off If show_repo_age is set to off, got_get_repo_age() returns without setting the timestamp. got_get_repo_age() is also used by the branch listing to show how old they are however, and we end up rendering the stack garbage. Instead, respect `show_repo_age off' one layer above, and always return a timestamp in got_get_repo_age(). While here, initialize the timestamp to zero so it's set also in case of failures. Issue reported on IRC by xs, thanks!


dropping unnecessary strlen()s ok jamsek, stsp


change got_get_repo_tags' limit argument to size_t The function already carefully avoids wrapping around zero. While here add a sanity check for limit == 0, like what was previously done for got_get_repo_commits().


gotwebd: make got_get_repo_commits take a size_t and while here make sure 0 is rejected. requested by, improvements and ok stsp@


gotwebd: simplify got_get_repo_commits(): don't traverse all the commits! In some cases (e.g. limit=1 for DIFF action) we could end up traversing all the commits instead of fetching just the one requested. Needless to say, this makes the diff page extremely slow. reported by and ok stsp@


gotwebd: fix some got_error_from_errno2/3 calls it's not printf-like so %s don't make sense. Tweak the order of the arguments to obtain the intended output.


gotwebd: avoid needless double fseek() got_gotweb_closefile() already takes care of rewinding before truncating and closing, so no need to replicate here. ok stsp@


gotwebd: lower log priority of unexpected disconnections no need to be so loud when a client disconnects earlier than expected, log it only in verbose mode. Don't log GOT_ERR_CANCELLED too since that is only used to communicate the callers that we need to stop. ok stsp@


oops, one was missing


got_operations.c: use consistently a space before labels makes diff prettier and easier to read; instead of the label we have the function name in the hunk line.


remove fsync() from got_gotweb_closefile() discussed with millert@


rename got_gotweb_flushfile -> got_gotweb_closefile suggested and ok millert@


make got_gotweb_flushfile always close the file ok millert@


rename some local fdN vars after previous change


simplify got_gotweb_openfile/flushfile Return only the FILE *, and require only that to close subsequently. Having to manage the file descriptor too makes using these functions unnecessary complex. millert@ agrees


include sha2.h too where sha1.h is included In preparation for wide sha256 support; stsp@ agrees. Change done mechanically with find . -iname \*.[cy] -exec sam {} + X ,x/<sha1\.h>/i/\n#include <sha2.h>


gotwebd: abort tree and blob as well


gotwebd: abort blame if the client disconnect midway thru Without setting err when the callback fails we continue the blame machinery.


fix mistaken instances returning NULL instead of err While here, for consistency, check dup() return value for -1 rather than < 0. ok stsp@